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Adobe Acrobat 9 Professional for Windows

Publisher
Adobe Systems
http://www.adobe.com

Retail Cost
Educational discount for California community colleges:
http://www.foundationccc.org
Adobe Online Store
http://store.adobe.com/store/main.jhtml

System Requirements
See Adobe Acrobat application for Windows and OS X software requirements
Currently not possible to create tagged-PDF documents directly from MS Office
applications in OS X

Description
Adobe Systems PDF format is widely used online for dissemination of documents. A PDF (portable document format) file is a graphical file that is an exact
image of a document originally created by another application (e.g., MS Word
file) and then converted by Adobe Acrobat into PDF format. A PDF document
can be viewed using Adobe Reader, which is a free viewer program that provides
access to the PDF document. The Adobe Reader viewer allows users to view and
enter information into a PDF document (where applicable) as well as enlarge the
viewing area of the document.
Accessible PDF documents can be created using the Adobe Acrobat software
application in conjunction with Microsoft Word, Excel, PowerPoint 2000/
XP/2003/2007 applications. The use of Adobe Acrobat and a supported wordprocessing application creates a “tagged” PDF document, where document presentation is separated from document content. Assistive computer technology
applications have the capacity to then read the “tagged” PDF document to communicate information to the user. Basic Use Instructions for downloading and
installing the latest versions of Acrobat Reader as well as additional Acrobat plugins to increase the functionality and accessibility can be found at:
http://access.adobe.com.
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While this manual focuses on the use of Adobe Acrobat 9.0 Professional to make
content accessible, it is possible to use versions 6.0 and later Standard or Professional as well (Note: Acrobat Standard does not support form development).

Creating a New PDF Document
Creating a new PDF document offers the most flexibility to insure accessibility is
designed into the document. Adobe Acrobat 9.0 is designed to work effectively
with MS Office 2003/XP applications and later (i.e., Word 2003/XP, PowerPoint
2003/XP, etc.) to create a “tagged” PDF structure. Acrobat 9.0 can also support
the generation of tagged PDF documents from other programs, such as Open Office or applications using PDFLib.
Before a document can be translated to the PDF document format from MS Word,
it is necessary to check the conversion settings of the Adobe Acrobat PDFMaker
within Microsoft Office. The default settings should produce a tagged PDF document from MS Word.
To check conversion settings:
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1.

Open a document in the Microsoft Office application.

2.

Choose Adobe PDF from the menu bar and select “Change Conversion
Settings”.

3.

Make sure that “Enable accessibility and reflow with Tagged PDF” is
checked.

4.

Select “OK”.
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Creating the PDF Document
1.

Create/open the document in the Microsoft Office application.

2.

Use Styles and Formatting tools in MS Office to control the presentation of the document. For example, to identify headings, use the Style
menu in the Formatting toolbar to designate various headings or text
content in the document. Styles can be manipulated under Styles and
Formatting from Format in the menu bar.

3.

Choose “Adobe PDF” from the menu bar and select “Convert to Adobe
PDF” (alternatively, click the Convert to Adobe PDF button on the application toolbar).

4.

Name and save the file to begin the conversion process.

5.

Open Adobe Acrobat and view the document to verify the document
was processed correctly.

PDFs with Images
If using images in a PDF document created from MS Word/Excel/PowerPoint, it
is possible to add a text description for the image. This method should be used for
image content that is relatively simple and does not require extensive description
of the image. If a longer description of the image is necessary to fully explain
its content, consider inserting a more detailed description of the image within the
document text preceding and/or following the image. For additional information
regarding adding text descriptions to images, visit:
http://www.webaim.org/techniques/images/
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To insert a text description
1.

Create/open the document in the Microsoft Office application.

2.

Select the image and perform a right-mouse button click and select
“Format Picture” from the options (you may also select the image and
choose “Format” from the menu bar and then “Picture”).

3.

Under the “Web” tab, enter a short text description of the image.

4.

Select “OK” and continue with the document creation.

Adding Alternative Text after Tagging
Some situations will require you to add alternative text to images or figures after
adding tags to a PDF document (adding tags will be covered later in the manual).
See the information under the TouchUp Reading Order tool for instructions to add
text descriptions after completing the tagging process in Adobe Acrobat.

Converting Existing PDF Documents
PDF documents created using Acrobat Distiller or other basic PDF printing
programs generally result in a PDF document that does not contain a document
structure (i.e., tags). Depending on the visual layout and design of the document,
this may lead to increased difficulty for assistive computer technology to gain access to the document content in a logical reading fashion. The following recommendations are designed to provide guidance when having to choose what type
of method is most appropriate to create an accessible PDF document. Generally
speaking, it is better to revert to the original file format (e.g., MS Word) when attempting to recreate a PDF as the document can be created with a “tagged” document structure.
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Recommendations when using MS Office applications
If the original document is available, open that file in a Microsoft Office application (if possible). Format the presentation of the document using the style elements found under Format on the menu bar. Remember to add appropriate image
descriptions to graphics and figures. Once this process is complete, follow the
directions under the Creating the PDF Document section.
If the original document is not available, open the PDF document in Adobe
Acrobat. Follow the directions in the next section, titled “Adding Tags to a PDF
Document”.
If the PDF document exists in an “Image Only” file format, it will be necessary to
apply some type of Optical Character Recognition (OCR) to the PDF document
image to yield a document containing text content (not a graphic representation of
the image). This is similar to starting with a TIFF document from a scanner, and
then using an OCR program such as OmniPage, ABBY FineReader, or the Text
Recognition tool in Acrobat to recognize the actual letters and symbols on the
page. The Text Recognition tool in Acrobat may be found under the “Document”
heading from the menu bar.

Adding Tags to a PDF Document
Adobe Acrobat 9 allows users to create a tagged PDF document from untagged
PDF files. Tagged PDF documents can provide enhanced user accessibility
depending on the document design as well as the capacity to save a PDF document into alternate formats (e.g., HTML, Accessible Text, RTF, etc.). If creating electronic forms, it is necessary to use Adobe Acrobat Professional or Adobe
LiveCyle Designer (PC-only) to create accessible PDF-based forms.
Adding tags manually to a PDF document does have some limitations. While
Acrobat can automatically add tags to a PDF document, there is no guarantee
that the document content will be tagged in the correct reading order. Documents
that contain regions of high complexity, such as rich visual layouts, may result
in a tagged structure that does not follow the logical reading order of the original
document. Any graphics or charts in the PDF document may not be processed
correctly and may be rendered as “Figures” or “Inline Shapes”. It is necessary to
identify these items and add the appropriate alternative text descriptions.
Adobe Acrobat 9 includes the “TouchUp Reading Order” tool that allows an
author to specify a logical reading order of the PDF document as well as simplify
the process of adding image descriptions. The TouchUp Reading Order tool also
includes a Table Inspector to improve the accessibility of data tables within PDFdocuments.
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Adding Tags
1.

Open the PDF document that does not contain the tagged structure.

2.

Select Advanced > Accessibility > Add Tags to Document. This will
start the tagging process of the PDF document. After the program finishes processing the document, use Save As and save the file with a new
name.

3.

Open the new PDF document to check the logical order of the tagged
file.

Special Note
A shortcut method of assessing the logical reading order of a tagged PDF document is to save the PDF file as “Text (Accessible)”. This can be done from File >
Save As… and changing the “Save File As Type” option. Check the reading order
of the resulting text file for potential reading order errors.

The TouchUp Reading Order Tool
The TouchUp Reading Order tool was new for Adobe Acrobat 7 and fulfills a
similar role in Adobe Acrobat 9 by providing an opportunity to make corrections
to the document structure. After adding tags to a PDF document, the TouchUp
Reading Order tool will identify blocks of text, headings, figures, tables, and
formulas that are contained within the document structure. If the PDF document
contains images (or figures) containing pertinent information, then use the TouchUp Reading Order tool to add the appropriate text descriptions.
8
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While it is possible to manually add and restructure the tags in a PDF document,
it is recommended to use the “Add Tags to Document” function followed by the
TouchUp Reading Order tool to organize the logical flow of document information. Open the TouchUp Reading Order tool by:

1.

Selecting “Advanced” from the menu bar and choosing “Accessibility”.

2.

Choosing “TouchUp Reading Order”.

This will open the tool panel in which to make the necessary corrections to the
tagged information in the PDF document.
Information within the PDF document will be identified as separate regions with
a number in the upper left part of the region. This number identifies the logical
reading order of the text flow of the document.
Adding Content with the TouchUp Reading Order Tool
When you initially open the TouchUp tool, the PDF document will display the
various content regions and the reading order in which the regions will be recognized. However, it may be possible that during the tagging process, some content
is missed by the “Add Tags to Document” process. This requires the document
author to go back and add information to the PDF tag structure.
1.

Open the TouchUp Reading Order tool (Advanced > Accessibility >
TouchUp Reading Order).

9

Accessible PDF Documents with Adobe Acrobat 8

2.

Identify the region of text content that is not part of the page structure
(e.g., content will not be within a gray box). Using the cross-hair icon,
draw a box around the text information. Make sure that all the text
information you wish to include is encompassed by blue squares.

3.

Select the type of content using the reading order panel.

After you have identified the content type, you will be able to see a gray region
encompassing the area you selected. The TouchUp Reading Order tool can be
used to add headings, text, figures, tables, and form fields. It is the decision of
the author/designer as to how specific they wish to identify the information in the
document.
Removing Content with the TouchUp Reading Order Tool
In some cases, it will be necessary to remove content from the document structure. Content that is appropriate for removal may be visual images that are not
relevant to the content (e.g., “eye-candy”), information that is misrecognized by
the Add Tags to Document tool and does not contain value, or when temporarily
separating regions for restructuring.
1.

Open the TouchUp Reading Order tool (Advanced > Accessibility >
TouchUp Reading Order).

2.

Using the cross-hair icon, draw a box around the region of content you
wish to remove from the document structure.

3.

In the TouchUp Reading Order dialog window, select the “Background”
button. This will remove any gray regions from around the content as
well as remove the content from the document structure.

Special Note
By removing information from the document structure you are ensuring this information will not be communicated to an individual utilizing assistive computer
technologies and potentially limiting document access
Reclassifying Content with the TouchUp Reading Order Tool
After running the Add Tags to Document function, you may wish to reclassify the
information or correct any mistakes the “Add Tags” process may have created.
For instance, it is possible that the “Add Tags” process identifies each region on a
page as a “Figure”, which may not be the true nature of the content. (A description of the different content options is listed in the Adobe Acrobat Help menu,
under “TouchUp Reading Order Options”)
In addition to correcting the designation of the content, you may wish to create
Bookmarks from the different headings within the document. By specifying the
correct content as headings using the TouchUp Reading Order tool, it is possible
to automatically create a list of Bookmarks.
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Reclassifying a Region
1.

Open the TouchUp Reading Order tool (Advanced > Accessibility >
TouchUp Reading Order).

2.

If reclassifying the entire region, click on the number in the upper left
corner of the highlighted region. In the TouchUp Reading Order palette, identify the new content type (e.g., Text, Figure, Formula, etc.).

The selected region will change to the newly identified content type.
Reclassifying a Part of a Region
1.

Open the TouchUp Reading Order tool (Advanced > Accessibility >
TouchUp Reading Order).

2.

Using the cross-hair icon, draw a box around the content you wish to
change the document structure. Make sure that there is a blue outline
around all the content you are changing.

3.

In the TouchUp Reading Order palette, identify the new content type
(e.g., Text, Figure, Formula, etc.).

The regions should now split into two (or more) distinct regions. Regions can be
noted by the gray box surrounding the content as well as a number in the upper
left corner.
Evaluating and Controlling Reading Order
Adding tags to a PDF document can improve the accessibility of a document
by including structure that can be manipulated to ensure a logical reading order
to the document. However, the resulting structure that is created when applying the “Add Tags to Document” function may vary. As a result, it may become
necessary to reorder information using the TouchUp Reading Order tool such the
content is presented in a logical manner.
There are several methods for evaluating the logical reading order or the PDF
document content. You can save a PDF document as text and read the information, review the identified regions with the TouchUp tool, or inspect content using
the “Order” navigation tab.
Save as Text
1.

Choose “File” from the menu bar and select “Save As”.

2.

Under the “Save File As Type” menu, choose “Text (Accessible)”.

3.

Open the text file to review for errors in the logical flow of the document.
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This method will extract the text content of the PDF document (and associated
text descriptions, form field content, etc.) and provides a method to assess the
reading order of content in the PDF document. While this is not a precise test, it
can be used to quickly examine if there are major errors in how document content
may be rendered by assistive computer technology.
Using the TouchUp Reading Order Tool
1.

Open the TouchUp Reading Order tool (Advanced > Accessibility >
TouchUp Reading Order).

2.

Identify the two regions which are out of the correct reading order.
Move the cross-hairs to the number in the upper left corner of the region
you wish to move (the pointer should change to a “hand” icon).

3.

Click and drag the number to the new location within the other specified
region. The icon will change to a “caret” icon to assist you with precise
placement of the content. You may need to zoom into the document in
order to ensure correct placement.

The regions will automatically re-number to show the order in which information
will be organized in the PDF document structure. However, the regions will NOT
move visually on the PDF document.

Using the Order Tab
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1.

Select “View” on the menu bar and choose “Navigation Panels” and
select “Order”.

2.

The Order tab will demonstrate each page and the associated content on
each page. Child elements on each page represent the specific regions
of content and are numbered sequentially.
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3.

Move the child element to its appropriate position on the specific page.
This will reorder the sequence of the regions in the PDF document
structure and change the logical reading order.

Content that is changed in the Order tab will also be changed in the Tags panel.
However, the information in the Order panel is specific to the content of the page
rather than the structural elements of the page. When you need to change specific
structural elements (e.g., language setting, etc.), it is necessary to use the Tags
panel.
Using the Tags Panel
The Tags Panel provides the user with the ability to view the underlying structure of the PDF document. With the Tags Panel, the PDF document creator can
manipulate the structure of the document as well as the informational content
contained within the various tag levels. For example, a PDF document author can
insert text descriptions, reclassify headings, etc. for various elements after creating the PDF document.
Special Note
It is not recommended to manipulate tags in order to specify PDF reading order.
Instead, use the TouchUp Reading Order tool (previous section) in order to improve the logical flow of information in a document.
1.

Open a tagged PDF document in Adobe Acrobat. A non-tagged PDF
document will not show information in the Tags Palette.

2.

Select “View” from the menu bar and then select “Navigation Panels”.

3.

Choose “Tags” from the menu. Drag the “Tags” panel to the left side of
the screen next to the tab labeled “Bookmark”. This will provide easy
access to the Tags Panel while working on a document.
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Once the tagged structure of the PDF document is revealed, it is relatively easy to
make changes to the content structure. Simply select the appropriate level heading where you wish to make the change and click the right-mouse button. The
menu will provide different options based on the heading content you have selected. For instance, it is not possible to add a New Child Element to the actual
content in the Tags Palette, but you may add a New Child Element to the heading
associated with the appropriate content. In this way, it is possible to add alternative text for graphics or provide the necessary accessibility options when creating
forms for PDF documents.
It may be difficult to locate the specific tag for a given image (or text block) when
working in a document. It may be easier to locate content and the respective tag
by enabling the “Highlight Content” feature in the Tags Panel. The Highlight
Content feature is available from the “Option” menu in the Tags Panel or by performing a right-mouse button click on a tag.
Often tagged levels will appear in the Tags Panel, but not refer to page content
or improperly refer to PDF document content. It is possible to remove (or add)
information to make the PDF document content more accessible to assistive computer technology.
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Fixing Tables
Tables provide the ability to visually present related pieces of information in a
quick and easy format. Similar to data tables on the Web, assistive computer technology may not be able to recognize table headers and render the content information in a recognizable manner to the individual. Rather, the user is relegated to
navigating through the table, hearing information while attempting to discern relationships between the various pieces of information. To create a table for a PDF
document, begin by using the Table formatting option in the appropriate word
processing program. Once you have converted your document to a PDF, you can
use the Table Inspector tool to include additional structure to improve accessibility for assistive computer technologies.
Special Note
Do not use “spaces” or “tabs” to visually format a table as this will create the
incorrect content in the tagged PDF document!
Table Inspector
New since Adobe Acrobat 8 is the Table Inspector for including the appropriate
markup for PDF-based data tables. The Table Inspector can be accessed from the
TouchUp Reading Order Tool and used to define the table headers and/or table
data in a data table. Defining such elements can assist in the recognition of the
table information when accessed using assistive computer technology.
Defining Table Headers
1.

Open the PDF document containing the data table to be repaired and
enable the TouchUp Reading Order Tool (ensure the PDF document has
been tagged as a “Table” or the Table Inspector will not be available).

2.

In the PDF, select the numerical value in the table region. Once the
table has been selected, press the Table Inspector button in the TouchUp
Reading Order Tool.

3.

By default, table header cells will have a red background. If a table
header is not properly shaded, click on the cell and then right-click to
open the Table Cell Properties.

4.

Define the table header cell by selecting the appropriate radio button
and choose the scope from the drop-down list (i.e., Row, Column, Both,
None). The scope value sets that specific cell information as the header
content for the entire table row or column.

5.

Press “OK” to return to the Table Inspector interface and finish adding
table header information to the appropriate row or column cells.
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While assistive computer technology may recognize the <Table> tag in the tagged
PDF, it may not recognize the correct column and row heading information even
after this content is properly identified. It is recommended to add this information to a PDF data table even if subsequent testing with assistive technology does
not reveal improvements to the table interpretation. This is a current issue with
assistive computer technology and future versions should be able to support such
tagging.
Description of PDF Table Tags
For those who use the Table Inspector,
•

The <Table> element should be the first markup “tag” before any content in the table is described.

•

Following the <Table> element, a <THead> and <TBody> may be the
next child tags. The <THead> and <TBody> tags separate the table into
the header or body elements.

•

Under the <THead> and <TBody> tags, the <TR> element should be
the next child element as this contains all the information for the first,
second, third, etc., row. <TR> is the table markup for Table Row.

•

After <TR>, the next child element should be either <TD> or <TH>.
<TD> is the markup for Table Data and represents the information
within a specific cell. <TH> is the markup for Table Header and represents the header data for a specific column or row.

Forms with Adobe Acrobat Pro
Forms in PDF documents allow users to enter content into a form field and print
the PDF page or save the document to file. Similar to Web page forms, PDF
document forms can be created as a one-line Text box, Combo Box, List Box, or
Radio Button. Additionally, information can be added to PDF forms to improve
the ability of assistive computer technology to access the form field and prompt
the user to input the correct information. Forms that users can enter information
with the computer are called “interactive forms”.
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Another application that you may wish to consider is Adobe LiveCycle Designer
8. This tool allows for the easy creation of electronic forms and generates a
tagged PDF file upon completion. This tool is recommended if you are using
forms that may vary in layout or content over time and will significantly reduce
the necessary time to re-create accessible PDF forms. More information about
using Adobe’s LiveCycle Designer is available in the next section.
Special Note
It is very important to not use keyboard characters to visually format the form
fields (e.g., creating lines for signatures using the “underscore” character, etc.).
Rather, use Adobe Acrobat Professional or the Adobe LiveCycle Designer tool to
create these visual references when constructing PDF forms.
You must first create a tagged PDF document before adding the necessary form
tags. Follow the instructions “Creating a New PDF Document” if you do not
have a tagged PDF document.
1.

Turn on the Tags tab. Under the “Options” menu in the Tags Palette,
enable “Highlight Content” and “Tag Annotations”.

2.

Choose the content in the tag structure that immediately precedes where
the form field will be located. For instance, if you are going to enter a
form field after the “First Name:” text, then it is necessary to select the
tag with the correct text.

3.

Select the appropriate form tool from the formatting bar.

4.

Create a form field of the desired size by clicking the mouse button and
dragging the crosshairs to the correct dimensions. When you create this
form field, the necessary form tags will automatically be placed into the
correct location in the tags palette.

5.

Enter a unique form field name in the “Name” text field in the Field
Properties dialog box.

6.

Enter supporting information in the “Tool Tip” text field. The information provided in the “Tool Tip” text field can be accessed by assistive
computer technology to prompt the user to enter the correct information.

7.

Under the “Appearance” tab, choose the options you desire for your
form field. Under the “Line Style” option, you may select “Underlined”
to visually represent a line for information.

The correct tag will automatically be added to the tags palette at the location you
specified before drawing in the necessary form field.
The benefit of this tag is that it will provide information to individuals using assistive computer technology to navigate and complete the appropriate form field
elements.
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Radio Buttons and Checkboxes
If your form requires the use of radio buttons and checkboxes, make sure to use
these form input elements correctly. Radio buttons should be used when you
wish to have only one answer reported (i.e., True or False, Male or Female, etc.).
Checkboxes should be used when you wish to have none or more than one answer
reported (i.e., A and B, Lunch and Dinner, etc.).
In either case, it is possible to identify the export value of the radio button and
checkbox for a specific form input element. In the field properties window, select
the “Options” tab and enter a value for “Export Value”. This information will be
spoken when using a screen-reader.
For additional information on creating PDF document forms, reference the Adobe
Acrobat 9.0 Help Topics. Additional information can also be found in Advanced
Techniques for Creating Accessible PDF Files manual from Adobe Systems. For
forms that require periodic updating and editing, it is recommended to review
Adobe Designer as this may streamline accessible PDF form creation.

PDF Documents and Web Browsers
Adobe Acrobat (and Adobe Reader) both offer the capability to view PDF documents from within the web browser interface. However, this integration can make
it very difficult for individuals with visual impairments (or using screen-readers)
to gain access to the PDF document content. It is possible to disable PDF integration with web browsers by following the steps below.
For Adobe Acrobat
1.

Open Adobe Acrobat under the Administrator profile.

2.

Choose “Edit” from the menu bar and select “Preferences”.

3.

Select “Internet”, and then uncheck “Display PDF in Browser” and
“Check browser settings when starting Acrobat”.

4.

Select “OK”.

For Adobe Reader
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1.

Open Adobe Reader by double-clicking on the desktop icon or starting
it from the Start menu.

2.

From the Edit menu, select Preferences, then Options on the left side of
the dialog box.

3.

In the Web Browser options, deselect the “Display PDF in Browser”
option and click OK.
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Using JAWS with Adobe Reader
Description
Forms Mode
Virtual Cursor On
Virtual Find
Links List
Next Page
Previous Page
Go to Page
Go to First Page
Go to Last Page

Keystroke
ENTER
NUM PAD PLUS
CTRL+F
INSERT+F7
CTRL+PAGE DOWN
CTRL+PAGE UP
CTRL+SHIFT+N
CTRL+SHIFT+PAGE UP
CTRL+SHIFT+PAGE DOWN

Using Window-Eyes with Adobe Reader
The Window-Eyes screen-reader application uses the basic HTML navigation
commands to read PDF documents. Below are commands for using the Adobe
Reader application. For specific information about Window-Eyes support for
Adobe Reader, please review the Help menu in Window-Eyes.
Description
Forms Mode
Virtual Cursor On
Search
Links List
Next Page
Previous Page
Go to Page
Go to First Page
Go to Last Page

Keystroke
ENTER
NUM PAD PLUS
CTRL+F
INS + TAB
CTRL+PAGE DOWN
CTRL+PAGE UP
CTRL+SHIFT+N
CTRL+SHIFT+PAGE UP
CTRL+SHIFT+PAGE DOWN
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Forms with Adobe LiveCycle Designer
Adobe LiveCycle Designer 8 comes with Adobe Acrobat Professional (PC-only)
and can be used to create accessible, interactive PDF forms. LiveCycle Designer
allows for a drag-and-drop method to create form fields and generates a tagged
PDF file upon completion. This tool is recommended if you are using forms that
may vary in layout or content over time and will significantly reduce the necessary time to re-create accessible PDF forms. Additionally, the LiveCycle Designer interface can be used to embed specific instructions into different form fields to
improve form functionality with assistive computer technologies.
The following information is a basic guide to creating PDF-based forms that support assistive computer technologies with Designer. For a full description of the
features and options to use with Adobe LiveCycle Designer, it is recommended
to review the Help menu on Using LiveCycle Designer > Creating Accessible
Forms.

Screen-Reader Precedence
Adobe LiveCyle Designer allows a form author to set specific content that may be
heard by individuals using screen-reading applications. The Screen-Reader Precedence option can be set to the following options: Custom Text, Tool Tip, Caption,
Name, and None. Only one of these options will be communicated to the screenreader, so it is not possible to set the precedence to Custom Text and have the Tool
Tip information communicated. Depending on the complexity of the form, select
one of these options to support the form user.
To provide customized instructions, open the Accessibility Palette and set the
Screen-Reader Precedence option as “Custom Text”. Enter information into the
Custom Screen Reader Text field to communicate to the screen-reader specific instructions. This may be a useful option when communicating information necessary for successful form completion in highly complex form designs.
A form author may decide to set the Screen Reader Precedence to the Tool Tip
option, instead. In this situation, the Screen Reader Precedence is set to Tool Tip
and the form author would enter text information into the Tool Tip field. The
Tool Tip becomes available to all users as it is viewable when the user hovers the
mouse pointer over the form object and would be spoken to an individual using a
screen-reader.
Other options that can be considered for screen-reader precedence are: the form
Caption; the form Name; or None (i.e., nothing is communicated to the screenreader). Depending on the screen-reader precedence option selected a screenreader user will receive different information. It is important to consider what
information – and amount – will be necessary to ensure successful form completion by all potential users.
20
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Text Fields
A text field is an edit box for a user to enter some type of text information. This
may be as simple as an entry field to collect an individuals name, address, or
phone number.
1.

Drag the Text Field object from the Library to the appropriate location
on the page.

2.

Change the caption to the appropriate text content (e.g., First Name: ).

The caption is the text content associated with the form field.
3.

Switch to the Accessibility Palette (right-click on the form object and
choose Palettes > Accessibility). In the “Tool Tip” region, enter the
instruction you wish to communicate to the individual using assistive
technology and set the Screen Reader Preference option to “Tool Tip”.
This will cause the screen-reader to speak the Tool Tip information.

4.

If you do not wish to use the Tool Tip field and the form caption contains significant information for successful form completion, set the
Screen Reader Preference option to “Caption”.

Radio Buttons
Radio buttons are distinguished as “either-or” answers; multiple selections are not
permitted for a group of radio buttons. When one radio button is selected, the others in the group are deselected. If there is a need to allow multiple answers for a
particular question, consider a group of checkboxes.
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If you are working with a series of radio buttons, it is important to group these
radio buttons together. Radio buttons are grouped together with the same “Name”
value (Object Palette > Binding). When adding a set of radio buttons to the page,
a new radio button will automatically be grouped with other radio buttons of the
same Name value. If a new form object (not a radio button) is added to the page
and then additional radio buttons are added, the new radio buttons will form their

own separate group (different Name value). It is important to recognize the correct group of radio buttons selected when applying accessibility information.
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1.

Drag the Radio Button form object from the Library to the appropriate
location on the page. Radio buttons with the same “Name” value will
be grouped together (under the Object Palette).

2.

Select the group of radio buttons and open the Accessibility Palette.
Enter the question in the Custom Screen Reader Text field. Set the
Screen Reader Precedence option to “Custom Text”. This will speak the
question to the individual as they move between the radio buttons.

3.

Change the caption to the appropriate text content for each radio button.
The caption is the text content associated with that specific radio button.

4.

In the Object Palette, open the Bindings tab and uncheck the box “Specify Item Values”. This will result in the screen-reader speaking the
radio button caption as the individual moves through the radio button
group.
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Checkboxes
Checkboxes are used when there may be multiple responses to a specific question
as opposed to radio buttons that only allow one response. Checkboxes are not
grouped in the same manner as radio buttons and so a different process is necessary to ensure the appropriate information is communicated to the individual.
1.

Drag the Checkbox form object from the Library to the appropriate
location on the page.

2.

Change the checkbox caption to the appropriate text content. The caption is the text content associated with the form field.

3.

Switch to the Accessibility Palette (right-click on the form object and
choose Palettes > Accessibility). In the Tool Tip region or Custom
Screen Reader Text region, enter the question and answer for the specific checkbox. Set the Screen Reader Precedence to the Custom Text
or Tool Tip option.

Drop-Down Lists
A drop-down list may be another option instead of radio buttons when expecting
the individual to select only one option. With drop-down lists, it is important to
avoid adding scripting to the object that triggers an automatic change when the
option is selected (i.e., when using the up/down arrow keys). This is usually accomplished by setting an “onChange” or “onSelect” type attribute. Drop-down
lists may also be opened using the Alt + Down Arrow keystroke to reveal all the
selection options.
1.

Drag the Drop-down List object from the Library to the appropriate
location on the page.

2.

Change the caption to the appropriate text content. The caption is the
text content associated with the form field.

3.

Switch to the Accessibility Palette (right-click on the form object and
choose Palettes > Accessibility). In the “Tool Tip” region, enter the
instruction you wish to communicate to the individual using assistive
technology and set the Screen Reader Preference option to “Tool Tip”.
This will cause the screen-reader to speak the Tool Tip information.

4.

If you do not wish to use the Tool Tip field and the form field caption
contains appropriate information for successful form completion, set the
Screen Reader Preference option to “Caption”.

For more information about creating accessible PDF-based forms, please review
the Help topic Using LiveCycle Designer > Creating Accessible Forms.
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Web Resources
Adobe Acrobat 9.0 Website
http://www.adobe.com
Accessibility Information at Adobe
http://www.adobe.com/accessibility
Accessibility Information and Support Acrobat Accessibility Resources
http://www.adobe.com/enterprise/accessibility/acrobat.html
On-Line Conversion Tools
http://www.adobe.com/products/acrobat/access_onlinetools.html
How to Create Accessible PDF Documents
http://www.adobe.com/products/acrobat/access_booklet.html
Creating Accessible Content
http://www.adobe.com/enterprise/accessibility/creating.html
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